Fix wspoon power fault error yaml install

Missing the ${D} on the install command - this still
managed to work on the older versions of yocto but
not with the latest one.

Also removed the PROVIDES=<recipe-name> line since
it's redundant.

Change-Id: I83127f0c457ec31bd99311371ec76abaf6fbc76a
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb
index 1b8276b..64c551f 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb
@@ -5,14 +5,13 @@
 inherit obmc-phosphor-license
 inherit phosphor-dbus-yaml
 
-PROVIDES += "witherspoon-pfault-analysis-error-native"
 require witherspoon-pfault-analysis.inc
 
 S = "${WORKDIR}/git"
 
 do_install_append() {
     SRC=${S}/org/open_power/Witherspoon
-    DEST=${yaml_dir}/org/open_power/Witherspoon
+    DEST=${D}${yaml_dir}/org/open_power/Witherspoon
     install -d ${DEST}
     install ${SRC}/Fault.errors.yaml ${DEST}
     install ${SRC}/Fault.metadata.yaml ${DEST}