meta-phosphor: logging-yaml-provider: allow 'yaml' subdirs

Most repositories now put their dbus and phosphor-logging YAML into
a `yaml` subdirectory.  Enhance the bbclass to support either in the
root or in the `yaml` subdirectory.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I30a104088d4ac9696e9072b33ec8e91c4a718f10
diff --git a/meta-phosphor/classes/phosphor-logging-yaml-provider.bbclass b/meta-phosphor/classes/phosphor-logging-yaml-provider.bbclass
index f51e262..0f550cf 100644
--- a/meta-phosphor/classes/phosphor-logging-yaml-provider.bbclass
+++ b/meta-phosphor/classes/phosphor-logging-yaml-provider.bbclass
@@ -5,15 +5,21 @@
 do_install:append() {
     for yaml_d in ${LOGGING_YAML_SUBDIRS} ;
     do
-        if [ ! -d ${S}/${yaml_d} ];
+        if [ -d ${S}/${yaml_d} ];
         then
+            yaml_base=${S}
+        elif [ -d ${S}/yaml/${yaml_d} ];
+        then
+            yaml_base=${S}/yaml
+        else
             continue
         fi
 
-        for yaml_f in $(find ${S}/${yaml_d} -name "*.errors.yaml" -or \
+
+        for yaml_f in $(find ${yaml_base}/${yaml_d} -name "*.errors.yaml" -or \
             -name "*.metadata.yaml") ;
         do
-            subpath=$(realpath --relative-to=${S} ${yaml_f})
+            subpath=$(realpath --relative-to=${yaml_base} ${yaml_f})
             install -d $(dirname ${D}${yaml_dir}/$subpath)
 
             install -m 0644 ${yaml_f} ${D}${yaml_dir}/$subpath