meta-openembedded: subtree update:466fd78ac6..41fe46157c

Callaghan, Dan (2):
      firewalld: add UPSTREAM_CHECK_URI
      add new recipes for python-lrparsing, python3-lrparsing

Khem Raj (2):
      mongodb: Remove non building arches from COMPATIBLE_HOST
      uim: Fix cross-builds

Martin Jansa (1):
      libmicrohttpd: backport the fix for building with older gnutls

Oleksandr Kravchuk (4):
      libyui: update to 3.6.0
      libyui-ncurses: udpate to 2.52.0
      sanlock: update to 3.6.0
      tesseract-lang: update to 4.0.0

Randy MacLeod (1):
      crash: update from 7.2.6 to 7.2.7

Robert Yang (8):
      python-asn1crypto: extend to nativesdk
      python-incremental: Drop broken nativesdk
      fuse: Fix installed-vs-shipped for nativesdk
      keyutils: Fix installed-vs-shipped for nativesdk
      libnet-ssleay-perl: Drop broken native
      libnet-dns-sec-perl: Drop broken native
      iperf3: Drop broken native
      spice: Drop broken native

Trevor Gamblin (1):
      haveged: upgrade v1.9.4 -> v1.9.6

Zang Ruochen (5):
      xterm: upgrade 348 -> 349
      python-cmd2: upgrade 0.9.16 -> 0.9.17
      python-protobuf: upgrade 3.9.1 -> 3.9.2
      python-alembic: upgrade 1.2.0 -> 1.2.1
      python-paste: upgrade 3.2.0 -> 3.2.1

Change-Id: I4491ea47f5e54f4f3843a77c720d0a89304c36a5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-graphics/xorg-app/xterm_349.bb b/meta-openembedded/meta-oe/recipes-graphics/xorg-app/xterm_349.bb
new file mode 100644
index 0000000..137a165
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/xorg-app/xterm_349.bb
@@ -0,0 +1,34 @@
+require recipes-graphics/xorg-app/xorg-app-common.inc
+SUMMARY = "xterm is the standard terminal emulator for the X Window System"
+DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses"
+
+LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=c7faceb872d90115e7c0ad90e90c390d"
+
+SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz"
+
+SRC_URI[md5sum] = "194012229738f74bc44e7c0f5f6bf0c8"
+SRC_URI[sha256sum] = "39a6a3d3724f9a0a068f8cc353ab0c82831f0a43abb24470d933af299658475f"
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
+
+EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
+                 --x-libraries=${STAGING_LIBDIR} \
+                 FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
+                 --disable-imake \
+                 --disable-rpath-hack \
+                 --disable-setuid \
+                 --with-app-defaults=${datadir}/X11/app-defaults \
+                 "
+
+B = "${S}"
+
+do_configure() {
+    gnu-configize --force
+    sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
+    oe_runconf
+}
+
+# busybox can supply resize too
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "resize"