meta-openembedded: subtree update:466fd78ac6..41fe46157c

Callaghan, Dan (2):
      firewalld: add UPSTREAM_CHECK_URI
      add new recipes for python-lrparsing, python3-lrparsing

Khem Raj (2):
      mongodb: Remove non building arches from COMPATIBLE_HOST
      uim: Fix cross-builds

Martin Jansa (1):
      libmicrohttpd: backport the fix for building with older gnutls

Oleksandr Kravchuk (4):
      libyui: update to 3.6.0
      libyui-ncurses: udpate to 2.52.0
      sanlock: update to 3.6.0
      tesseract-lang: update to 4.0.0

Randy MacLeod (1):
      crash: update from 7.2.6 to 7.2.7

Robert Yang (8):
      python-asn1crypto: extend to nativesdk
      python-incremental: Drop broken nativesdk
      fuse: Fix installed-vs-shipped for nativesdk
      keyutils: Fix installed-vs-shipped for nativesdk
      libnet-ssleay-perl: Drop broken native
      libnet-dns-sec-perl: Drop broken native
      iperf3: Drop broken native
      spice: Drop broken native

Trevor Gamblin (1):
      haveged: upgrade v1.9.4 -> v1.9.6

Zang Ruochen (5):
      xterm: upgrade 348 -> 349
      python-cmd2: upgrade 0.9.16 -> 0.9.17
      python-protobuf: upgrade 3.9.1 -> 3.9.2
      python-alembic: upgrade 1.2.0 -> 1.2.1
      python-paste: upgrade 3.2.0 -> 3.2.1

Change-Id: I4491ea47f5e54f4f3843a77c720d0a89304c36a5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-security/keyutils/keyutils_1.6.bb b/meta-openembedded/meta-oe/recipes-security/keyutils/keyutils_1.6.bb
index dca86f3..572143a 100644
--- a/meta-openembedded/meta-oe/recipes-security/keyutils/keyutils_1.6.bb
+++ b/meta-openembedded/meta-oe/recipes-security/keyutils/keyutils_1.6.bb
@@ -40,6 +40,18 @@
     oe_runmake DESTDIR=${D} install
 }
 
+do_install_append_class-nativesdk() {
+    install -d ${D}${datadir}
+    src_dir="${D}${target_datadir}"
+    mv $src_dir/* ${D}${datadir}
+    par_dir=`dirname $src_dir`
+    rmdir $src_dir $par_dir
+
+    install -d ${D}${sysconfdir}
+    mv ${D}/etc/* ${D}${sysconfdir}/
+    rmdir ${D}/etc
+}
+
 do_install_ptest () {
     cp -r ${S}/tests ${D}${PTEST_PATH}/
     sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh