meta-openembedded: subtree update:466fd78ac6..41fe46157c

Callaghan, Dan (2):
      firewalld: add UPSTREAM_CHECK_URI
      add new recipes for python-lrparsing, python3-lrparsing

Khem Raj (2):
      mongodb: Remove non building arches from COMPATIBLE_HOST
      uim: Fix cross-builds

Martin Jansa (1):
      libmicrohttpd: backport the fix for building with older gnutls

Oleksandr Kravchuk (4):
      libyui: update to 3.6.0
      libyui-ncurses: udpate to 2.52.0
      sanlock: update to 3.6.0
      tesseract-lang: update to 4.0.0

Randy MacLeod (1):
      crash: update from 7.2.6 to 7.2.7

Robert Yang (8):
      python-asn1crypto: extend to nativesdk
      python-incremental: Drop broken nativesdk
      fuse: Fix installed-vs-shipped for nativesdk
      keyutils: Fix installed-vs-shipped for nativesdk
      libnet-ssleay-perl: Drop broken native
      libnet-dns-sec-perl: Drop broken native
      iperf3: Drop broken native
      spice: Drop broken native

Trevor Gamblin (1):
      haveged: upgrade v1.9.4 -> v1.9.6

Zang Ruochen (5):
      xterm: upgrade 348 -> 349
      python-cmd2: upgrade 0.9.16 -> 0.9.17
      python-protobuf: upgrade 3.9.1 -> 3.9.2
      python-alembic: upgrade 1.2.0 -> 1.2.1
      python-paste: upgrade 3.2.0 -> 3.2.1

Change-Id: I4491ea47f5e54f4f3843a77c720d0a89304c36a5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb b/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
index cc28e6e..8948ebf 100644
--- a/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
+++ b/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
@@ -4,11 +4,11 @@
 LIC_FILES_CHKSUM = "file://COPYING;md5=ab2826b41ca0ff4030d38cc39791d1c8"
 SECTION = "inputmethods"
 
-SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2"
-
+SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2 \
+    file://0001-Fix-to-set-libedit-path-from-configure-option-proper.patch \
+"
 SRC_URI_append_class-target = "\
     file://uim-module-manager.patch \
-    file://0001-fix-bug-for-cross-compile.patch \
 "
 SRC_URI[md5sum] = "01c7bd5d0d4f3a9f6f5befe6f57a470b"
 SRC_URI[sha256sum] = "34599bbcc4e5ab87832370763e38be5100984a64237555e9234a1ea225a0fadc"
@@ -22,6 +22,9 @@
 
 LEAD_SONAME = "libuim.so.1"
 
+COMPATIBLE_HOST_riscv64 = "null"
+COMPATIBLE_HOST_riscv32 = "null"
+
 inherit distro_features_check autotools pkgconfig gettext qemu gtk-immodules-cache
 
 REQUIRED_DISTRO_FEATURES = "x11"
@@ -29,6 +32,7 @@
 GTKIMMODULES_PACKAGES = "uim-gtk2.0 uim-gtk3"
 
 EXTRA_OECONF += "--disable-emacs \
+    --with-libedit=${STAGING_EXECPREFIXDIR} \
     --without-scim \
     --without-m17nlib \
     --without-prime \