Fix path to udev rules files

Use nonarch_base_libdir instead of base_libdir, because the files are
always in /lib/udev/rules.d/. On ppc64le base_libdir is lib64, and the
files end up in the wrong spot.

Signed-off-by: Anton Blanchard <anton@ozlabs.org>
Change-Id: I3c24dae293f4166f1ed1826d09d4bde7cd7d0357
diff --git a/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb b/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
index 1b91ba3..c7273a0 100644
--- a/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
+++ b/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
@@ -26,8 +26,8 @@
 SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
 
 do_install:append() {
-    install -d ${D}/lib/udev/rules.d
-    install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
+    install -d ${D}/${nonarch_base_libdir}/udev/rules.d
+    install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/${nonarch_base_libdir}/udev/rules.d
 }
 
 TMPL = "mboxd-reload@.service"