meta-facebook: move nvme_config.json into project layer

Description:
Very few machines use phosphor-nvme and the current common meta-facebook
bbappend forces every machine to create a bogus empty JSON file in order
to prevent bitbake missing SRC_URI errors.  Move these configs out of
the common layer and into the machine-specific layer.

Change-Id: Ie8558db2ed394a414e9dce70f73d2eb8693448f9
Signed-off-by: Delphine CC Chiu <Delphine_CC_Chiu@wiwynn.com>
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
index d495c8d..84df1a1 100644
--- a/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
+++ b/meta-facebook/meta-bletchley/recipes-phosphor/sensors/phosphor-nvme_%.bbappend
@@ -5,6 +5,7 @@
 SRC_URI:append:bletchley = " \
     file://nvme-json-rewrite \
     file://nvme-json-rewrite.conf \
+    file://nvme_config.json \
 "
 
 RDEPENDS:${PN}:bletchley += "bash"
@@ -12,6 +13,9 @@
 do_install:append:bletchley() {
         install -d ${D}${libexecdir}/${PN}/
         install -m 0755 ${WORKDIR}/nvme-json-rewrite ${D}${libexecdir}/${PN}/
+
+        install -d ${D}${sysconfdir}/nvme
+        install -m 0644 -D ${WORKDIR}/nvme_config.json ${D}${sysconfdir}/nvme
 }
 
 SYSTEMD_OVERRIDE:${PN}:append:bletchley = " \