JSON file with DCMI capabilities.

This JSON file is containing the DCMI capabilities, this can
be overriden for individual systems based on the capabilities.

Change-Id: I67231fc8ea6da4e13856da296fc7c24e3122c559
Signed-off-by: Dhruvaraj Subhashchandran <dhruvaraj@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index 583c0b1..eb3f902 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -58,6 +58,7 @@
 
 SRC_URI += "file://merge_yamls.py \
             file://dev_id.json \
+            file://dcmi_cap.json \
             "
 
 HOSTIPMI_PROVIDER_LIBRARY += "libapphandler.so"
@@ -69,6 +70,7 @@
 FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
 FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
 FILES_${PN}_append = " ${datadir}/ipmi-providers/dev_id.json"
+FILES_${PN}_append = " ${datadir}/ipmi-providers/dcmi_cap.json"
 FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
 
 # Soft Power Off
@@ -110,6 +112,8 @@
     install -d ${D}${datadir}/ipmi-providers
     install -m 0644 -D ${WORKDIR}/dev_id.json \
         ${D}${datadir}/ipmi-providers/dev_id.json
+    install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
+        ${D}${datadir}/ipmi-providers/dcmi_cap.json
 }
 # python-pyyaml-native is installed by do_configure, so put this task after
 addtask merge_sensors after do_configure before do_compile