Network: Bring libnl into the openbmc image

We would be writing a new app in the phosphor-netwokd
repo.

libnl would be used for IPC mechanism between kernel and
user space process.

In issue 2931 we need to talk with kernel for certain
NCSI commands(nelink) through libnl.

NCSI commands are as follows

NCSI_CMD_PKG_INFO: which returns information on packages and their
associated channels.

NCSI_CMD_SET_INTERFACE which allows a specific package or
package/channel combination to be set as the preferred choice.

NCSI_CMD_CLEAR_INTERFACE which clears any preferred setting

Partilally Resolves openbmc/openbmc#2931

Change-Id: I9b90a43d44c082a403ec93aa6a5a1f1cdb68a992
Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/network/network.bb b/meta-phosphor/common/recipes-phosphor/network/network.bb
index b792472..3170d56 100644
--- a/meta-phosphor/common/recipes-phosphor/network/network.bb
+++ b/meta-phosphor/common/recipes-phosphor/network/network.bb
@@ -16,9 +16,12 @@
 DEPENDS += "sdbusplus sdbusplus-native"
 DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
 DEPENDS += "phosphor-logging"
+DEPENDS += "libnl"
 
 RDEPENDS_${PN} += "libsystemd"
 RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
 RDEPENDS_${PN} += "phosphor-logging"
+RDEPENDS_${PN} += "libnl"
+RDEPENDS_${PN} += "libnl-genl"
 
 S = "${WORKDIR}/git"