obmc-console: Convert configs from socket-id to console-id

As of 9a8f30ec5b58 ("obmc-console: Introduce console-id, deprecate
socket-id") in obmc-console `console-id` is preferred over `socket-id`.
Convert all in-tree configurations to `console-id` to enable removal of
support for the deprecated `socket-id` configuration option.

Change-Id: Ifd50603c378cfed5eb793b829b8296b7964e4194
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index 7f1d7f9..2d33233 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -64,9 +64,9 @@
                         # Link the custom configuration to the required location
                         ln -sr ${D}${sysconfdir}/${BPN}.conf ${D}${sysconfdir}/${BPN}/server.${OBMC_CONSOLE_TTYS}.conf
                 else
-                        # Otherwise, remove socket-id from the shipped configuration to
+                        # Otherwise, remove console-id from the shipped configuration to
                         # align with the lack of a client configuration file
-                        sed -ri '/^socket-id =/d' ${D}${sysconfdir}/${BPN}/server.${OBMC_CONSOLE_TTYS}.conf
+                        sed -ri '/^console-id =/d' ${D}${sysconfdir}/${BPN}/server.${OBMC_CONSOLE_TTYS}.conf
                 fi
         fi
 }