blob: cc50f90f70bcb3983d3cd998b5d95d5dda9b4ad8 [file] [log] [blame]
SUMMARY = "A stream-oriented XML parser library"
DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
HOMEPAGE = "https://github.com/libexpat/libexpat"
SECTION = "libs"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
file://run-ptest \
"
UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
SRC_URI[sha256sum] = "6f262e216a494fbf42d8c22bc841b3e117c21f2467a19dc4c27c991b5622f986"
EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
RDEPENDS:${PN}-ptest += "bash"
inherit cmake lib_package ptest
do_install_ptest:class-target() {
install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
}
BBCLASSEXTEND += "native nativesdk"
CVE_PRODUCT = "expat libexpat"