blob: 33602694540bb87801e9c0c551a060c0befbf7fd [file] [log] [blame]
SUMMARY = "Lossless data compressor based on the LZMA algorithm"
HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
DESCRIPTION = "Lzip is a lossless data compressor with a user interface similar to the one of gzip or bzip2. Lzip uses a simplified form of the Lempel-Ziv-Markov chain-Algorithm (LZMA) stream format, chosen to maximize safety and interoperability."
SECTION = "console/utils"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
file://decoder.cc;beginline=3;endline=16;md5=18c279060cd0be128188404b45837f88 \
"
SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz"
SRC_URI[sha256sum] = "c3342d42e67139c165b8b128d033b5c96893a13ac5f25933190315214e87a948"
B = "${WORKDIR}/build"
do_configure[cleandirs] = "${B}"
CONFIGUREOPTS = "\
'--srcdir=${S}' \
'--prefix=${prefix}' \
'--exec-prefix=${exec_prefix}' \
'--bindir=${bindir}' \
'--datadir=${datadir}' \
'--infodir=${infodir}' \
'--sysconfdir=${sysconfdir}' \
'CXX=${CXX}' \
'CPPFLAGS=${CPPFLAGS}' \
'CXXFLAGS=${CXXFLAGS}' \
'LDFLAGS=${LDFLAGS}' \
"
do_configure () {
${S}/configure ${CONFIGUREOPTS}
}
do_install () {
oe_runmake 'DESTDIR=${D}' install
# Info dir listing isn't interesting at this point so remove it if it exists.
if [ -e "${D}${infodir}/dir" ]; then
rm -f ${D}${infodir}/dir
fi
}
BBCLASSEXTEND = "native nativesdk"