blob: 8c11fb52e0f641a97b07d6c006193539dca0757b [file] [log] [blame]
SUMMARY = "GNOME editor"
SECTION = "x11/gnome"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
GNOMEBASEBUILDCLASS = "meson"
DEPENDS = " \
gdk-pixbuf-native \
gtk+3 \
gsettings-desktop-schemas \
libpeas \
libsoup-2.4 \
gspell \
gtksourceview4 \
tepl \
"
inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check mime-xdg python3targetconfig
def gnome_verdir(v):
return oe.utils.trim_version(v, 1)
REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI[archive.sha256sum] = "7a9b18b158808d1892989165f3706c4f1a282979079ab7458a79d3c24ad4deb5"
# gobject-introspection is mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
GIR_MESON_OPTION = ""
GTKDOC_MESON_OPTION = "gtk_doc"
PACKAGES += "${PN}-python"
FILES:${PN} += " \
${datadir}/dbus-1 \
${datadir}/metainfo \
"
FILES:${PN}-python += " \
${PYTHON_SITEPACKAGES_DIR} \
"
RDEPENDS:${PN} += "gsettings-desktop-schemas"
RRECOMMENDS:${PN} += "source-code-pro-fonts"