blob: dca476cede7d608d443239074299e511986f3878 [file] [log] [blame]
SUMMARY = "Web-based MySQL administration interface"
HOMEPAGE = "http://www.phpmyadmin.net"
# Main code is GPLv2, vendor/tecnickcom/tcpdf is under LGPLv3, js/jquery is under MIT
LICENSE = "GPLv2 & LGPLv3 & MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://vendor/tecnickcom/tcpdf/LICENSE.TXT;md5=dd6470bbcd3436ca317f82d34abaf688 \
file://js/vendor/jquery/MIT-LICENSE.txt;md5=de877aa6d744cc160ff41c26a8e4811f \
"
SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \
file://apache.conf \
"
SRC_URI[sha256sum] = "c562feddc0f8ff5e69629113f273a0d024a65fb928c48e89ce614744d478296f"
UPSTREAM_CHECK_URI = "https://www.phpmyadmin.net/downloads/"
UPSTREAM_CHECK_REGEX = "phpMyAdmin-(?P<pver>\d+(\.\d+)+)-all-languages.tar.xz"
S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
inherit allarch
do_install() {
install -d ${D}${datadir}/${BPN}
cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN}
chown -R root:root ${D}${datadir}/${BPN}
# Don't install patches to target
rm -rf ${D}${datadir}/${BPN}/patches
install -d ${D}${sysconfdir}/apache2/conf.d
install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
# Remove a few scripts that explicitly require bash (!)
rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
}
FILES:${PN} = "${datadir}/${BPN} \
${sysconfdir}/apache2/conf.d"
RDEPENDS:${PN} += "bash php-cli"