meta-openembedded: subtree update:a2928764c2..19528ba2a6

Adrian Bunk (1):
      libqmi: Replace clang patch with configure option

Bartosz Golaszewski (3):
      yad: new package
      zenity: new package
      unclutter-xfixes: new package

Khem Raj (2):
      mycroft: Remove alsa-oss from rdeps
      bigbuckbunny: Use faster download mirrors

Oleksandr Kravchuk (21):
      capnproto: update to 0.7.0
      ddrescue: update to 1.24
      fmt: update to 6.0.0
      jsonrpc: update to 1.2.0
      libburn: update to 1.5.0
      libdvdread: update to 6.0.1
      libev: update to 4.27
      libmodplug: update to 0.8.9.0
      libnice: update to 0.1.16
      libopus: update to 1.3.1
      libsass: update to 3.6.1
      libuv: update to 1.32.0
      libsocketcan: update to 0.0.11
      tree: update to 1.8.0
      xclock: update to 1.0.9
      xcursorgen: update to 1.0.7
      xfontsel: update to 1.0.6
      xmag: update to 1.0.6
      xmessage: update to 1.0.5
      xorg-sgml-doctools: update to 1.11
      evtest: update to 1.34

Peiran Hong (1):
      tcpdump: Fix CVE-2017-16808

Change-Id: I4f2f575382cd34404d10470ece0aae7620487902
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/zenity/zenity_3.32.0.bb b/meta-openembedded/meta-gnome/recipes-gnome/zenity/zenity_3.32.0.bb
new file mode 100644
index 0000000..295288b
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/zenity/zenity_3.32.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Display dialog boxes from the command line and shell scripts"
+SECTION = "x11/gnome"
+LICENSE = "GPLv2+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
+
+inherit distro_features_check gnomebase gettext
+
+DEPENDS = "gtk+3"
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
+    file://0001-build-don-t-generate-manual.patch \
+"
+
+SRC_URI[archive.md5sum] = "ba2b2a13248773b4ec0fd323d95e6d5a"
+SRC_URI[archive.sha256sum] = "e786e733569c97372c3ef1776e71be7e7599ebe87e11e8ad67dcc2e63a82cd95"
+GNOME_COMPRESS_TYPE="xz"
+
+do_install_append() {
+    # Remove gdialog compatibility helper - we don't want to pull in perl
+    rm ${D}${bindir}/gdialog
+}