meta-openembedded: subtree update:a2928764c2..19528ba2a6

Adrian Bunk (1):
      libqmi: Replace clang patch with configure option

Bartosz Golaszewski (3):
      yad: new package
      zenity: new package
      unclutter-xfixes: new package

Khem Raj (2):
      mycroft: Remove alsa-oss from rdeps
      bigbuckbunny: Use faster download mirrors

Oleksandr Kravchuk (21):
      capnproto: update to 0.7.0
      ddrescue: update to 1.24
      fmt: update to 6.0.0
      jsonrpc: update to 1.2.0
      libburn: update to 1.5.0
      libdvdread: update to 6.0.1
      libev: update to 4.27
      libmodplug: update to 0.8.9.0
      libnice: update to 0.1.16
      libopus: update to 1.3.1
      libsass: update to 3.6.1
      libuv: update to 1.32.0
      libsocketcan: update to 0.0.11
      tree: update to 1.8.0
      xclock: update to 1.0.9
      xcursorgen: update to 1.0.7
      xfontsel: update to 1.0.6
      xmag: update to 1.0.6
      xmessage: update to 1.0.5
      xorg-sgml-doctools: update to 1.11
      evtest: update to 1.34

Peiran Hong (1):
      tcpdump: Fix CVE-2017-16808

Change-Id: I4f2f575382cd34404d10470ece0aae7620487902
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/farsight/libnice_0.1.16.bb b/meta-openembedded/meta-oe/recipes-support/farsight/libnice_0.1.16.bb
new file mode 100644
index 0000000..7bd6478
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/farsight/libnice_0.1.16.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Interactive Connectivity Establishment library"
+DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)."
+HOMEPAGE = "http://nice.freedesktop.org/wiki/"
+
+LICENSE = "LGPLv2.1 & MPLv1.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \
+                    file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
+                    file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \
+"
+
+SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
+SRC_URI[md5sum] = "5ad936c43d3c6d33117b2c64982f2fd9"
+SRC_URI[sha256sum] = "06b678066f94dde595a4291588ed27acd085ee73775b8c4e8399e28c01eeefdf"
+
+DEPENDS = "glib-2.0 gnutls"
+
+PACKAGECONFIG ??= "gstreamer1.0"
+PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
+PACKAGECONFIG[gstreamer1.0] = "--with-gstreamer,--without-gstreamer,gstreamer1.0 gstreamer1.0-plugins-base"
+
+inherit autotools pkgconfig gtk-doc gobject-introspection
+
+EXTRA_OECONF += "--without-gstreamer-0.10"
+
+FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
+FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
+FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
+FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
+
+do_configure_prepend() {
+    mkdir ${S}/m4 || true
+}
+
+do_compile_append() {
+    for i in $(find ${B} -name "*.pc") ; do
+        sed -i -e s:${STAGING_DIR_TARGET}::g \
+               -e s:/${TARGET_SYS}::g \
+                  $i
+    done
+}