state-manager: Favor ALLOW_EMPTY

A number of recipes remove PN from the package list.  While this
seems to work it is unconventional and puts us into dusty corners
of oe-core/bitbake.

Adopt a more conventional approach with ALLOW_EMPTY_${PN} = "1".

Tested: Built phosphor-state-manager and validated package contents
Change-Id: Ic52764ba9e716a7ce5c1fd8d6c7fd419ef985ac2
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
index 269f574..0889fcb 100644
--- a/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-state-manager.bb
@@ -15,10 +15,8 @@
     ${PN}-host-check \
     ${PN}-reset-sensor-states \
 "
-PACKAGES =+ "${STATE_MGR_PACKAGES}"
-PACKAGES_remove = "${PN}"
-RDEPENDS_${PN}-dev = "${STATE_MGR_PACKAGES}"
-RDEPENDS_${PN}-staticdev = "${STATE_MGR_PACKAGES}"
+PACKAGE_BEFORE_PN += "${STATE_MGR_PACKAGES}"
+ALLOW_EMPTY_${PN} = "1"
 
 DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"