meta-ibm: set critical services for IBM systems

This takes the default critical services list from meta-phosphor and
appends on extra services IBM is interested in.

Ideally, there would be an easy way to just append an extra file to the
command line but this is going to need some more thought. For now, just
override the entire file.

Tested:
- Booted witherspoon up in QEMU and verified new json file was loaded
  and that stopping one of the new critical services resulted in a
  dump, error log, and BMC Quiesced state.

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: Icf5db5331072cbcbd0359e0b789b664e31423124
diff --git a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 089d04c..71739b3 100644
--- a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -14,3 +14,12 @@
 # system power on if chassis power is in a bad state
 RRECOMMENDS:${PN}-chassis = "${PN}-chassis-check-power-status"
 
+# Override critical services to monitor with IBM file
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+FILES:${PN}-bmc:append = " ${sysconfdir}/phosphor-service-monitor-default.json"
+SRC_URI:append = " file://phosphor-service-monitor-default.json"
+do_install:append() {
+    install -d ${D}${sysconfdir}/phosphor-systemd-target-monitor
+    install -m 0644 ${WORKDIR}/phosphor-service-monitor-default.json \
+        ${D}${sysconfdir}/phosphor-systemd-target-monitor/
+}