meta-google: sslh: Ensure conf2struct files are not regenerated

We sometimes have a race condition in the git checkout process that
causes the source file timestamp to be newer than the generated ones.
The generation process is currently broken, but the necessary files are
bundled in the source tree.

Change-Id: I81fb707d5b16f88032d7022da97563bf6ccc78f5
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-extended/networking/sslh_git.bb b/meta-google/recipes-extended/networking/sslh_git.bb
index b683571..5a7a9b1 100644
--- a/meta-google/recipes-extended/networking/sslh_git.bb
+++ b/meta-google/recipes-extended/networking/sslh_git.bb
@@ -7,9 +7,6 @@
 SRCREV = "517e4ad5b4d57dae396790882bd4629947be1632"
 S = "${WORKDIR}/git"
 
-inherit perlnative
-
-DEPENDS += "conf2struct-native"
 DEPENDS += "libbsd"
 DEPENDS += "libcap"
 DEPENDS += "libconfig"
@@ -22,10 +19,16 @@
 EXTRA_OEMAKE += "USELIBBSD=1"
 EXTRA_OEMAKE += "USESYSTEMD=1"
 
+do_patch() {
+  # Workaround timestamps of the source being later than the generated,
+  # vendored output files. This non-determinism sometimes causes failures.
+  sed -i '/conf2struct/d' ${S}/Makefile
+}
+
 do_compile() {
-    oe_runmake
+  oe_runmake
 }
 
 do_install() {
-    oe_runmake install
+  oe_runmake install
 }