blob: 553b9cfa1817abf9b7b1b12d1e4726855653978e [file] [log] [blame]
SUMMARY = "World timezone definitions, modern and historical"
HOMEPAGE = "http://pythonhosted.org/pytz"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
inherit pypi setuptools3 ptest
SRC_URI[sha256sum] = "01a0681c4b9684a28304615eba55d1ab31ae00bf68ec157ec3708a8182dbbcd0"
RDEPENDS:${PN}:class-target += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-doctest \
${PYTHON_PN}-io \
${PYTHON_PN}-pickle \
${PYTHON_PN}-pprint \
${PYTHON_PN}-threading \
"
BBCLASSEXTEND = "native nativesdk"
SRC_URI += " \
file://run-ptest \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/pytz
install -d ${D}${PTEST_PATH}/pytz/tests
cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
cp -f ${S}/README.rst ${D}${PTEST_PATH}/
}