meta-raspberrypi: subtree update:3ae288aa38..a953fc0f9b

Andrei Gherzan (2):
      raspberrypi-firmware: Update to current HEAD
      linux-raspberrypi: Bump to 4.19 recipe to 4.19.88

Leon Anavi (1):
      pi-bluetooth: Runtime depends on udev-rules-rpi

Michael Baisch (1):
      linux-raspberrypi.inc: no longer set CONFIG_LOCALVERSION to empty string

Pierre-Jean Texier (3):
      linux-raspberrypi-rt: bump to revision e2e9cec
      rpi-gpio: bump to version 0.7.0
      raspi-gpio: bump to revision 4edfde1

Change-Id: Ibd557330128fe2b6afbefd2234e411b45f265aeb
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
new file mode 100644
index 0000000..fcce88f
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/rpi-gpio_0.7.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
+HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
+
+PYPI_PACKAGE = "RPi.GPIO"
+inherit pypi distutils3
+
+SRC_URI += "file://0001-Remove-nested-functions.patch"
+SRC_URI[md5sum] = "777617f9dea9a1680f9af43db0cf150e"
+SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f"
+
+COMPATIBLE_MACHINE = "^rpi$"