meta-phosphor: image-signing: Make script POSIX compliant

The script was comparing string with `==` that works in bash but not in
`dash`.

Change it to `=` so that it is more POSIX compliant.

Tested: Verify the build passes with SIGNING_PUBLIC_KEY defined with
        both `bash` and `dash`.

Signed-off-by: Lei YU <yulei.sh@bytedance.com>
Change-Id: Id825cd111adeae5b1e50ea4f25603728cc122375
diff --git a/meta-phosphor/classes/image_types_phosphor.bbclass b/meta-phosphor/classes/image_types_phosphor.bbclass
index 717c453..63de40e 100644
--- a/meta-phosphor/classes/image_types_phosphor.bbclass
+++ b/meta-phosphor/classes/image_types_phosphor.bbclass
@@ -356,7 +356,7 @@
 make_signatures() {
     signing_key="${SIGNING_KEY}"
 
-    if [ "${INSECURE_KEY}" == "True" ] && [ -n "${SIGNING_PUBLIC_KEY}" ]; then
+    if [ "${INSECURE_KEY}" = "True" ] && [ -n "${SIGNING_PUBLIC_KEY}" ]; then
         echo "Using SIGNING_PUBLIC_KEY"
         signing_key=""
     fi