meta-nuvoton: ipmi: change PCI device-id for NPCM8xx

There are two kinds of PCI device-id for NPCM7xx and NPCM8xx respectively. For NPCM7xx the device-id is using 0x0750 and NPCM8xx is using 0x0850. Thus, change this PCI device-id for supporting NPCM8xx platform.

Use this variable that can help to build host tool burn_my_bmc compatible with different platforms and make in-band firmware update work well.

Signed-off-by: Tim Lee <timlee660101@gmail.com>
Change-Id: I8a23699eab879d3b2620ee47fa9fe46a1e5ef524
diff --git a/meta-nuvoton/recipes-phosphor/ipmi/phosphor-ipmi-flash_%.bbappend b/meta-nuvoton/recipes-phosphor/ipmi/phosphor-ipmi-flash_%.bbappend
new file mode 100644
index 0000000..2fd550b
--- /dev/null
+++ b/meta-nuvoton/recipes-phosphor/ipmi/phosphor-ipmi-flash_%.bbappend
@@ -0,0 +1,3 @@
+# NPCM8xx is using 0x0850 as PCI device-id.
+NUVOTON_PCI_DID = "2128"
+EXTRA_OEMESON:append:npcm8xx = " -Dnuvoton-pci-did=${NUVOTON_PCI_DID}"