meta-ibm: Add mihawk ipmi yaml.

Add mihawk's ipmi sensor and fru yaml.

Tested: Use ipmi command to get the sensor list and fru data.

(From meta-ibm rev: 05c9a2734de75271837313f0e1794c58df50e990)

Signed-off-by: Ben Pai <Ben_Pai@wistron.com>
Change-Id: Ic85af9b0cc1b44a3377fa919e63ab04dbff7a31c
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
index d0dbd60..245693a 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
@@ -6,7 +6,7 @@
 inherit allarch
 inherit mrw-xml
 
-SRC_URI = " \
+SRC_URI_ibm-ac-server = " \
     file://acx22-ipmi-fru-bmc.yaml \
     file://acx22-ipmi-fru-not-sent-by-host.yaml \
     file://acx22-ipmi-hwmon-sensors.yaml \
@@ -14,7 +14,13 @@
     file://acx22-ipmi-occ-sensors.yaml \
     file://acx22-ipmi-sensors-mrw.yaml \
     "
-
+SRC_URI_mihawk = " \
+    file://acx22-ipmi-fru-bmc.yaml \
+    file://acx22-ipmi-hwmon-sensors.yaml \
+    file://acx22-ipmi-inventory-sensors.yaml \
+    file://acx22-ipmi-occ-sensors.yaml \
+    file://acx22-ipmi-sensors-mrw.yaml \
+    "
 DEPENDS = " \
     mrw-native \
     mrw-perl-tools-native \
@@ -23,10 +29,13 @@
 
 S = "${WORKDIR}"
 
-ACx22_IPMI_EXTRA_FRU_READ_YAMLS = " \
+ACx22_IPMI_EXTRA_FRU_READ_YAMLS_ibm-ac-server = " \
     acx22-ipmi-fru-bmc.yaml \
     acx22-ipmi-fru-not-sent-by-host.yaml \
     "
+ACx22_IPMI_EXTRA_FRU_READ_YAMLS_mihawk = " \
+    acx22-ipmi-fru-bmc.yaml \
+    "
 ACx22_IPMI_EXTRA_SENSOR_YAMLS = " \
     acx22-ipmi-hwmon-sensors.yaml \
     acx22-ipmi-occ-sensors.yaml \