sdbusplus: split library and python scripts

(From meta-phosphor rev: 7aba8156394c5608565e549a1b9de3e9a91b5ff1)

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I471c25139f9fef8c976613a9f8c25d7617c1aa8c
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index a440003..1709906 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -12,38 +12,15 @@
         ${PYTHON_PN}-mako-native \
         ${PYTHON_PN}-pyyaml-native \
         "
-RDEPENDS_sdbus++ += " \
-        ${PYTHON_PN} \
-        ${PYTHON_PN}-inflection \
-        ${PYTHON_PN}-mako \
-        ${PYTHON_PN}-pyyaml \
-        "
-
-# sdbus++ has a handful of runtime dependencies on other python packages.
-# Bitbake doesn't do anything with RDEPENDS in native context because
-# native context doesn't have packages.
-#
-# While technically sdbus++ doesn't require its runtime dependencies to be
-# installed to build, work around the above native context behavior
-# by adding a build dependency so that clients don't have to DEPEND
-# on sdbus++ runtime dependencies manually.
-
-DEPENDS_append_class-native = " \
-        ${PYTHON_PN}-inflection-native \
-        ${PYTHON_PN}-mako-native \
-        ${PYTHON_PN}-pyyaml-native \
-        "
 
 PACKAGECONFIG ??= "libsdbusplus transaction"
 PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
 PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
 
-PROVIDES_prepend = "sdbus++ "
-PACKAGE_BEFORE_PN = "sdbus++"
-FILES_sdbus++_append = " ${bindir}/sdbus++"
-PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
-
-PACKAGECONFIG_remove_class-native = "libsdbusplus"
-PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
-
-BBCLASSEXTEND += "native nativesdk"
+# Remove unused sdbus++ contents (included in python3-sdbus++ package).
+do_install_append() {
+    rm ${D}/${bindir}/sdbus++
+    rmdir ${D}/${bindir} || true
+    rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR}
+    rmdir ${D}/${libdir}/${PYTHON_DIR} || true
+}