Add shadow package to the rootfs

The binaries of the shadow package like useradd, groupadd is needed
for the user management functionality.

Change-Id: Idfe506793ac8f452ad4de5589f0de00efaf4ce3b
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index a4aaeae..e3a57f1 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -103,3 +103,7 @@
         rm ${IMAGE_ROOTFS}${sysconfdir}/version
 }
 ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; "
+
+# The shadow recipe provides the binaries(like useradd, usermod) needed by the
+# phosphor-user-manager.
+ROOTFS_RO_UNNEEDED_remove = "shadow"