treewide: clean up recipe checks in OBMC_MACHINE_FEATURES

OBMC_MACHINE_FEATURES is a variable that probably shouldn't even exist
as all it does is provide a level of indirection to the real
MACHINE_FEATURES (in phosphor-base.inc, OBMC_ is added to the base).
There are a few recipes that have developed checks against
OBMC_MACHINE_FEATURES for enabling recipe-level features when they
should be checking the standard MACHINE_FEATURES variable.  Clean up
this recipe-level indirection.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Id437b93aa6c1de9a27726eea9b7e2c30e71ab3bf
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index 4a61ba3..fc7c39d 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -30,6 +30,6 @@
 RDEPENDS:${PN} += "openpower-libhei"
 
 # Conditionally pull in PHAL APIs, if available.
-PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
+PACKAGECONFIG ??= "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}"
 PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, ipl pdata"