treewide: clean up recipe checks in OBMC_MACHINE_FEATURES

OBMC_MACHINE_FEATURES is a variable that probably shouldn't even exist
as all it does is provide a level of indirection to the real
MACHINE_FEATURES (in phosphor-base.inc, OBMC_ is added to the base).
There are a few recipes that have developed checks against
OBMC_MACHINE_FEATURES for enabling recipe-level features when they
should be checking the standard MACHINE_FEATURES variable.  Clean up
this recipe-level indirection.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Id437b93aa6c1de9a27726eea9b7e2c30e71ab3bf
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index b78b85b..804084e 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -43,7 +43,7 @@
              -Dyamldir=${STAGING_DATADIR_NATIVE}/${PN} \
              -Dps-derating-factor=${POWER_SUPPLY_DERATING_FACTOR} \
              "
-EXTRA_OEMESON:append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' -Di2c-occ=enabled', '', d)}"
+EXTRA_OEMESON:append = "${@bb.utils.contains('MACHINE_FEATURES', 'i2c-occ', ' -Di2c-occ=enabled', '', d)}"
 
 OCC_ENABLE = "enable"
 OCC_DISABLE = "disable"