meta-quanta: s6q: Add x86-power-ctrl config files

These config files contains the gpio configuartion which will be used by
the x86 power control.

Tested: Tested and verified in S6Q.

Change-Id: I3e2684b2d7b0e6f3c6eb874569d5c82f6b733e02
Signed-off-by: P.K.Lee <p.k.lee@quantatw.com>
diff --git a/meta-quanta/meta-s6q/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-quanta/meta-s6q/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100755
index 0000000..95cb307
--- /dev/null
+++ b/meta-quanta/meta-s6q/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS:prepend:s6q := "${THISDIR}/${PN}:"
+SRC_URI:append:s6q = " file://power-config-host0.json"
+
+do_install:append:s6q() {
+    install -m 0755 -d ${D}/${datadir}/${BPN}
+    install -m 0644 ${WORKDIR}/power-config-host0.json ${D}${datadir}/${BPN}
+}