fans:monitor:witherspoon: Install config.json file

In prep for switching the witherspoon machine over to using a runtime
fan monitoring JSON configuration, install the configuration file into
the image now.

Tested:
    Verified both `monitor.yaml` and `config.json` in phosphor-fan
    Built/installed witherspoon image and config.json file present
    Verified YAML config still used instead of present JSON config

(From meta-ibm rev: 36206800a699a1429d30ad32a36e4f960ac6c7b4)

Change-Id: I75d72a2731f201d37d38c9d436eff2af522bc6da
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 10f3f22..cb89a3a 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -58,6 +58,7 @@
 # Enable the use of JSON on the fan applications that support it
 EXTRA_OECONF_append_witherspoon = " --enable-json"
 RDEPENDS_${PN}-presence-tach_append_witherspoon = " phosphor-fan-presence-config"
+RDEPENDS_${PN}-monitor_append_witherspoon = " phosphor-fan-monitor-config"
 
 # Set the appropriate i2c address used within the overridden phosphor-fan-control@.service
 # file that's used for witherspoon type(including witherspoon-tacoma) machines