meta-openembedded: subtree update:f623d8b574..936f2380bb

Alexander Vickberg (2):
      libwebsockets: upgrade to 4.1.6
      mbedtls: upgrade to 2.24.0

Bartosz Golaszewski (1):
      libgpiod: update v1.4.5 -> v1.6.2

Beniamin Sandu (1):
      trace-cmd: create recipe for version 2.9.1

Fabio Berton (2):
      beep: Add recipe for version 1.2.2
      linuxconsole: Add recipe for version 1.7.0

Gianfranco (1):
      dlt-daemon: add upstream patch to fix CVE-2020-29394

Kai Kang (1):
      colord: fix installed-vs-shipped error

Khem Raj (1):
      packagegroup-meta-python: Remove packages moved to core

Luca Boccassi (3):
      dbus-broker: rdepend on dbus-common
      dbus-brocker: upgrade 23 -> 24
      dbus-broker: upgrade 24 -> 25

Martin Jansa (1):
      nanopb: move to dynamic-layers

Michael Vetter (1):
      jasper: upgrade 2.0.22 -> 2.0.23

Philip Balister (1):
      spdlog: Fix recipe so other recipes can use spdlog with external fmt.

Robert Karszniewicz (1):
      firmwared: add recipe

Roland Hieber (5):
      pcsc-lite: provide pcsc-lite-lib-native explicitly for native build
      lockfile-progs: use DEBIAN_MIRROR in SRC_URI
      fbset: use DEBIAN_MIRROR in SRC_URI
      liboop: use upstream SRC_URI
      openct: use upstream SRC_URI

Senthil Selvaganesan (1):
      fcgiwrap: add recipe

Thomas Perrot (1):
      openocd: disable the support of ccache

Trevor Woerner (4):
      glmark2: update information
      glmark2: update to latest
      glmark2: add support for dispmanx
      glmark2: revert to previous behaviour

Vyacheslav Yurkov (1):
      python3-aiohttp: added missing RDEPENDs

Wang Mingyu (2):
      gensio: 2.1.4 -> 2.2.0
      ser2net: 4.2.0 -> 4.3.0

Zang Ruochen (7):
      dialog: upgrade 1.3-20200327 -> 1.3-20201126
      fmt: upgrade 7.1.2 -> 7.1.3
      hidapi: upgrade 0.10.0 -> 0.10.1
      opensc: upgrade 0.20.0 -> 0.20.1
      pugixml: upgrade 1.10 -> 1.11
      satyr: upgrade 0.31 -> 0.35
      nanopb: upgrade 0.4.3 -> 0.4.4

zhengruoqin (9):
      c-periphery: upgrade 2.2.4 -> 2.2.5
      crash: upgrade 7.2.8 -> 7.2.9
      dfu-util: upgrade 0.9 -> 0.10
      monit: upgrade 5.26.0 -> 5.27.1
      qpdf: upgrade 10.0.1 -> 10.0.4
      tcsh: upgrade 6.22.02 -> 6.22.03
      xserver-xorg-cvt-native: upgrade 1.20.5 -> 1.20.9
      zchunk: upgrade 1.1.6 -> 1.1.7
      libconfig-autoconf-perl: upgrade 0.318 -> 0.319

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I8371eb789fa288193da895bd51ce2160194809d8
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.2.0.bb b/meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.2.0.bb
new file mode 100644
index 0000000..424e176
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.2.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
+HOMEPAGE = "https://github.com/cminyard/gensio"
+LICENSE = "GPL-2.0 & LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
+                    file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
+                    "
+
+SRCREV = "4ec19138aa968dea34e4bc4e022c1ad7ed4c43c0"
+
+SRC_URI = "git://github.com/cminyard/gensio;protocol=https \
+           file://0001-Modify-parameter-of-function-sctp_gensio_alloc.patch"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+PACKAGECONFIG ??= "openssl tcp-wrappers"
+
+PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
+PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
+PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
+
+EXTRA_OECONF = "--without-python"
+
+RDEPENDS_${PN} += "bash"