meta-google: Add glome-login and glome-config

We have to use glome-config since the sample config is removed in
glome recipe. As a result, now glome depends on glome-config.

The platform also needs to overwrite these variables in their
bbappend files:
- glome-login.bb
  * GLOME_FALLBACK_SERV
  * GLOME_FALLBACK_OBJ
  * GLOME_HOSTNAME_SUFFIX
  * GLOME_BOARDSN_KEY
- glome-config.bb
  * GLOME_PUBLIC_KEY
  * GLOME_KEY_VERSION
  * GLOME_URL_PREFIX

Tested:
1) `bitbake obmc-phosphor-image` build passes
2) inplace update the image on a real machine
3) connect to it
The glome is enabled and login is successful

Signed-off-by: Leo Tu <leotu@google.com>
Change-Id: I21a48cbdcfea67772f143b4fc115f717e6d7cbc5
diff --git a/meta-google/recipes-google/console/glome_git.bb b/meta-google/recipes-google/console/glome_git.bb
index 42dcbda..418179f 100644
--- a/meta-google/recipes-google/console/glome_git.bb
+++ b/meta-google/recipes-google/console/glome_git.bb
@@ -8,16 +8,23 @@
 
 inherit meson pkgconfig
 
-DEPENDS += "openssl"
+DEPENDS += " \
+  openssl \
+  glome-config \
+  "
+RDEPENDS:${PN} += "glome-config"
 
 S = "${WORKDIR}/git"
 SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
 SRCREV = "978ad9fb165f1e382c875f2ce08a1fc4f2ddcf1b"
 
-FILES_${PN} += "${libdir}/security"
-
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
 PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
 
 EXTRA_OEMESON = "-Dtests=false"
+
+# remove the default glome config so it can be overridden by `glome-config`
+do_install:append() {
+  rm -f ${D}${sysconfdir}/glome/config
+}