rename libapphandler.so to libipmi20.so

this is the bitbake portion of the renaming of libapphandler to
libipmi20. The shared object contains much more than just app commands,
so it should be named something more generic.

Change-Id: I8e89252a32cb0a331bf31fccf0cff525bca556b0
Signed-off-by: Vernon Mauery <vernon.mauery@linux.intel.com>
(cherry picked from commit 06e58138a8ddaed752e401383e3c326791f59cfd)
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index f79974a..7a2f7c1 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -72,10 +72,10 @@
 
 SRC_URI += "file://merge_yamls.py "
 
-HOSTIPMI_PROVIDER_LIBRARY += "libapphandler.so"
+HOSTIPMI_PROVIDER_LIBRARY += "libipmi20.so"
 HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
 
-NETIPMI_PROVIDER_LIBRARY += "libapphandler.so"
+NETIPMI_PROVIDER_LIBRARY += "libipmi20.so"
 
 FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
 FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"