styhead: update WORKDIR usage
The latest yocto release(styhead,5.1) has made a significant change[1]
to the use of the WORKDIR parameter.
This is not the complete change required but gets us going in the right
direction.
[1]: https://docs.yoctoproject.org/next/migration-guides/migration-5.1.html#workdir-changes
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I4f184b361be69e7704a0657a4a00cdad981aff8a
diff --git a/meta-facebook/meta-yosemite4/recipes-networking/mctp/mctp_%.bbappend b/meta-facebook/meta-yosemite4/recipes-networking/mctp/mctp_%.bbappend
index 077f1b4..28605b3 100644
--- a/meta-facebook/meta-yosemite4/recipes-networking/mctp/mctp_%.bbappend
+++ b/meta-facebook/meta-yosemite4/recipes-networking/mctp/mctp_%.bbappend
@@ -14,17 +14,17 @@
override_dir=${D}${systemd_system_unitdir}/mctpd.service.d
install -d ${D}${systemd_system_unitdir}/mctpd.service.d
- install -m 0644 ${WORKDIR}/setup-local-eid.conf \
+ install -m 0644 ${UNPACKDIR}/setup-local-eid.conf \
${override_dir}/setup-local-eid.conf
- install -m 0644 ${WORKDIR}/setup-static-endpoints.conf \
+ install -m 0644 ${UNPACKDIR}/setup-static-endpoints.conf \
${override_dir}/setup-static-endpoints.conf
install -d ${D}${libexecdir}/mctp
- install -m 0755 ${WORKDIR}/mctp-config \
+ install -m 0755 ${UNPACKDIR}/mctp-config \
${D}${libexecdir}/mctp/
- install -m 0755 ${WORKDIR}/setup-static-endpoints \
+ install -m 0755 ${UNPACKDIR}/setup-static-endpoints \
${D}${libexecdir}/mctp/
- install -m 0755 ${WORKDIR}/nic-gpio-addrs \
+ install -m 0755 ${UNPACKDIR}/nic-gpio-addrs \
${D}${libexecdir}/mctp/
}