Add obmc-phosphor-buttons recipe.

Add obmc-phosphor-buttons_git.bb file and enable buttons

TestBy: export TEMPLATCONF=meta-intel/meta-s2600wf/conf/
        bitbake obmc-phosphor-buttons

(From meta-phosphor rev: 0d737656491b85b06ecb0aaa1290276abc98234f)

Change-Id: I09b182b2adc4d245a3b42794a2e133d940074d55
Signed-off-by: Kuiying Wang <kuiying.wang@intel.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
new file mode 100644
index 0000000..0ab155b
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "OpenBMC Buttons"
+DESCRIPTION = "OpenBMC All buttons"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+S = "${WORKDIR}/git"
+SRC_URI += "git://github.com/openbmc/phosphor-buttons.git"
+SRCREV = "f654267db9dafbd5727f113f29439ec7dfeaea8b"
+
+inherit cmake pkgconfig systemd
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Buttons.service"
+
+DEPENDS += " \
+    systemd \
+    sdbusplus \
+    phosphor-dbus-interfaces \
+    phosphor-logging \
+    nlohmann-json \
+    gpioplus \
+    "