recipe preparation for openpower PEL parser modules

The PEL parser for openpower-hw-diags requires some data files built by
openpower-libhei. There will eventually be another recipe for that will
use the same SRC_URI and SRCREV as openpower-libhei. So that information
has been moved to the openpower-libhei-rev.inc file. Then, the recipes
for both of these projects have been cleaned for readability.

Signed-off-by: Zane Shelley <zshelle@us.ibm.com>
Change-Id: Ib2141e53480d4b8a9afc767427e87bcefe02afc1
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index a31a584..ed042ed 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -1,4 +1,3 @@
-HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
 SUMMARY = "Hardware Diagnostics for POWER Systems"
 
 DESCRIPTION = \
@@ -7,17 +6,21 @@
     POWER Systems have the ability to diagnose the root cause of the failure \
     and perform any service action needed to avoid repeated system failures."
 
-PV = "0.1+git${SRCPV}"
+HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
+
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-inherit meson systemd
-
-S = "${WORKDIR}/git"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
 
 SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
 SRCREV = "6bc43c9b896724c27317ac50a88e5ddaa2882484"
 
+S = "${WORKDIR}/git"
+
+inherit meson systemd
+
 SYSTEMD_SERVICE_${PN} = "attn_handler.service"
 
 DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \