recipe preparation for openpower PEL parser modules

The PEL parser for openpower-hw-diags requires some data files built by
openpower-libhei. There will eventually be another recipe for that will
use the same SRC_URI and SRCREV as openpower-libhei. So that information
has been moved to the openpower-libhei-rev.inc file. Then, the recipes
for both of these projects have been cleaned for readability.

Signed-off-by: Zane Shelley <zshelle@us.ibm.com>
Change-Id: Ib2141e53480d4b8a9afc767427e87bcefe02afc1
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
index 59ed91c..183e2ed 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
@@ -1,17 +1,20 @@
-inherit meson
+SUMMARY = "Hardware Error Isolator for POWER Systems"
 
-SUMMARY = "Hardware Error Isolator Library"
-DESCRIPTION = "Hardware Error Isolator Library (libhei)"
+DESCRIPTION = \
+    "The library provides a set of tools to isolate hardware attentions driven \
+    by POWER Systems chip (processor chips, memory chips, etc.)."
+
+HOMEPAGE = "https://github.com/openbmc/openpower-libhei"
+
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-SRC_URI = "git://github.com/openbmc/openpower-libhei"
-
-PV = "0.1+git${SRCPV}"
-SRCREV = "0a905012d0e90ea32ca651883413cd84b56804d1"
+include openpower-libhei-rev.inc
 
 S = "${WORKDIR}/git"
 
+inherit meson
 inherit perlnative
 
-DEPENDS += "libxml2-native libxml-simple-perl-native libjson-perl-native"
+DEPENDS = "libxml2-native libxml-simple-perl-native libjson-perl-native"
+