meta-phosphor: ldap: nsswitch: add rootfs posthook

An ldap image feature was recently added.  If the image feature is used
without the distro feature, nsswitch will have the wrong content and the
function won't work.  Move this logic to a rootfs post hook so that the
distro feature is not required (and can be deprecated) and because this
is the expected way to make these sorts of modifications to base files
anyway.

(From meta-phosphor rev: 22de160c862b4cf4fee2a3f62e9bd7fad807344d)

Change-Id: I1bc69a96e833801c58bebce68b633e8550982fb8
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index 1c744ca..5961839 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -84,3 +84,11 @@
         echo "SYSTEMD_PAGER=" >> ${IMAGE_ROOTFS}${sysconfdir}/profile
         echo "export SYSTEMD_PAGER" >> ${IMAGE_ROOTFS}${sysconfdir}/profile
 }
+
+enable_ldap_nsswitch() {
+    sed -i 's/\(\(passwd\|group\|shadow\):\s*\).*/\1files ldap/' \
+        "${IMAGE_ROOTFS}${sysconfdir}/nsswitch.conf"
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "${@bb.utils.contains('IMAGE_FEATURES', 'obmc-user-mgmt-ldap', 'enable_ldap_nsswitch ;', '', d)}"
+