meta-ampere: Add Mt.Jade machine

Add initial Mt.Jade platform support with minimal configuration so that
the code can be compiled and booted on the Mt.Jade platform system.

Tested:
 1. Compile OpenBMC image for Mt.Jade successfully and can boot on
Mt.Jade.
 2. Login to console and WebUI successfully.

Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com>
Change-Id: Ib4c2c30be7fc0a13cc66f7eb1c8b9604e9a5292f
diff --git a/meta-ampere/meta-jade/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-ampere/meta-jade/recipes-kernel/linux/linux-aspeed_%.bbappend
new file mode 100644
index 0000000..109cc07
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend_mtjade := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+    file://${MACHINE}.cfg \
+    file://0001-ARM-dts-aspeed-Add-device-tree-for-Ampere-s-Mt.-Jade.patch \
+"
+