meta-openembedded: subtree update:18506b797b..c986cbed93

Adrian Bunk (7):
      gpsd: Backport a memory leak fix
      gpsd: Stop depending on chrpath-native
      klibc: Upgrade 2.0.6 -> 2.0.7
      gerbera: Upgrade 1.3.0 -> 1.3.2
      gstd: Fix the version number
      webrtc-audio-processing: Upgrade 0.3 -> 0.3.1
      vlc: Upgrade 3.0.6 -> 3.0.8

Andreas Müller (15):
      itstool: rework native shebang and add class to make native itstool work
      yelp-tools: use itstools.bbclass
      yelp-xsl: use itstool.bbclass
      yelp: use itstool.bbclass
      gnome-help.bbclass: Handle gnome-help files with new distro feature 'helpfiles'
      zenity: rework recipe
      dconf: extend to native build for upcoming gdm
      dconf-editor: upgrade 3.32.0 -> 3.34.0
      gtksourceview4: upgrade 4.2.0 -> 4.4.0
      gnome-menus3: upgrade 3.10.1 -> 3.32.0
      gnome-desktop3: upgrade 3.34.0 -> 3.34.1
      gnome-bluetooth: upgrade 3.32.1 -> 3.34.0
      gspell: upgrade 1.8.1 -> 1.8.2
      gnome-system-monitor: upgrade 3.32.0 -> 3.32.1
      network-manager-applet: upgrade 1.8.22 -> 1.8.23 / build with meson / cleanup

Luca Boccassi (4):
      dbus-broker: 19 -> 21
      dbus-broker: backport patches from master
      dbus-broker: build with SELinux if it's enabled via DISTRO_FEATURES
      dbus-broker: add patch to fix build with musl libc

Trevor Gamblin (1):
      rsyslog: upgrade from v8.1908.0 to v8.1910.0

Zang Ruochen (4):
      python-bitarray: upgrade 0.8.3 -> 1.0.1
      python-can: upgrade 2.2.1 -> 3.3.2
      python-daemonize: upgrade 2.4.7 -> 2.5.0
      xmlsec1: upgrade 1.2.28 -> 1.2.29

Zheng Ruoqin (2):
      keepalived: upgrade 2.0.16 -> 2.0.19
      postfix: upgrade 3.4.5 -> 3.4.7

Change-Id: Ibff272f163bb42473022825cfb17a284a0019e83
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-core/dbus/dbus-broker_21.bb b/meta-openembedded/meta-oe/recipes-core/dbus/dbus-broker_21.bb
new file mode 100644
index 0000000..d2d0510
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-core/dbus/dbus-broker_21.bb
@@ -0,0 +1,30 @@
+SUMMARY = "dbus broker"
+DESCRIPTION = "Drop-in replacement for dbus-daemon."
+
+SECTION = "base"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7b486c2338d225a1405d979ed2c15ce8"
+
+SRC_URI = "https://github.com/bus1/dbus-broker/releases/download/v${PV}/dbus-broker-${PV}.tar.xz"
+SRC_URI += " file://0001-launch-improve-error-handling-for-opendir.patch"
+SRC_URI += " file://0002-metrics-change-the-constant-used-for-invalid-timesta.patch"
+SRC_URI += " file://0003-dbus-socket-treat-MSG_CTRUNC-gracefully.patch"
+SRC_URI += " file://0004-launcher-fix-build-with-musl-libc.patch"
+SRC_URI[md5sum] = "a17886a92ab1e0bc2e4b1a274339e388"
+SRC_URI[sha256sum] = "6fff9a831a514659e2c7d704e76867ce31ebcf43e8d7a62e080c6656f64cd39e"
+
+inherit meson pkgconfig systemd distro_features_check
+
+DEPENDS = "expat systemd"
+DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'libselinux', '', d)}"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+SYSTEMD_SERVICE_${PN} = "${BPN}.service"
+
+FILES_${PN} += "${systemd_system_unitdir}"
+FILES_${PN} += "${systemd_user_unitdir}"
+FILES_${PN} += "${libdir}/systemd/catalog"
+
+EXTRA_OEMESON += " -Dselinux=${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'true', 'false', d)}"