phosphor-fan: Favor ALLOW_EMPTY

A number of recipes remove PN from the package list.  While this
seems to work it is unconventional and puts us into dusty corners
of oe-core/bitbake.

Adopt a more conventional approach with ALLOW_EMPTY_${PN} = "1".

Change-Id: I412bee4ef838c44af36260aa90f6a275751bd904
Tested: Built phosphor-fan and validated package contents
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
index d6ef365..9e4db30 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan.bb
@@ -27,12 +27,10 @@
         ${PN}-monitor \
 "
 
-PACKAGES_remove = "${PN}"
-PACKAGES += "${FAN_PACKAGES}"
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_BEFORE_PN += "${FAN_PACKAGES}"
 PACKAGECONFIG ?= "presence control monitor"
 SYSTEMD_PACKAGES = "${FAN_PACKAGES}"
-RDEPENDS_${PN}-dev = "${FAN_PACKAGES}"
-RDEPENDS_${PN}-staticdev = "${FAN_PACKAGES}"
 
 # --------------------------------------
 # ${PN}-presence-tach specific configuration