Introducing the Phosphor OpenBMC OE layer

 -Codifies the IBM vision for an OpenBMC build system.
 -Structured around a core DBUS API architecture.
 -Provides implementation flexibility within that architecture.
 -Provides sample qemuarm BSP layer.
diff --git a/classes/obmc-phosphor-py-daemon.bbclass b/classes/obmc-phosphor-py-daemon.bbclass
new file mode 100644
index 0000000..35c2714
--- /dev/null
+++ b/classes/obmc-phosphor-py-daemon.bbclass
@@ -0,0 +1,17 @@
+# Common code for dbus applications using python.
+
+inherit allarch
+inherit obmc-phosphor-systemd
+inherit obmc-phosphor-license
+
+RDEPENDS_${PN} += "python-dbus python-pygobject"
+SRC_URI += " \
+        file://${PN}.py \
+        "
+S = "${WORKDIR}"
+
+do_install_append() {
+        # install the script
+        install -d ${D}${sbindir}
+        install -m 0755 ${WORKDIR}/${PN}.py ${D}${sbindir}/${PN}
+}