blob: 4d13aa66c886ad789973a4e62a840e50065fbf0e [file] [log] [blame]
SUMMARY = "Install a Debian system into a subdirectory"
HOMEPAGE = "https://wiki.debian.org/Debootstrap"
SECTION = "devel"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608"
SRC_URI = "\
http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_${PV}.tar.gz \
file://0001-support-to-override-usr-sbin-and-usr-share.patch \
file://0002-support-to-override-usr-bin-arch-test.patch \
file://0001-do-not-hardcode-the-full-path-of-dpkg.patch \
"
SRC_URI[sha256sum] = "09e7f8795fee894b77994213ee3a588e9d8f96ddf5f93afdec91e9a137aa7866"
S = "${WORKDIR}/debootstrap"
DEPENDS = " \
virtual/fakeroot-native \
"
fakeroot do_install() {
oe_runmake 'DESTDIR=${D}' install
chown -R root:root ${D}${datadir}/debootstrap
}
BBCLASSEXTEND = "native nativesdk"