meta-yosemiteV2:Add x86-power-ctrl config files for multi host

These config files contains the gpio configuartion which will be used
by the x86 power control.
PGood config is dbus based gpio configuration is added for all hosts.

TESTED:Tested and verified in YosemiteV2.

Signed-off-by: Logananth Sundararaj <logananth.s@hcl.com>
Change-Id: I94c12545b26ac3bae8226ac6434e61c7c1ee9e06
diff --git a/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
index c119bac..862f2f1 100644
--- a/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
+++ b/meta-facebook/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -1,2 +1,13 @@
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 EXTRA_OECMAKE += "-DCHASSIS_SYSTEM_RESET=ON"
+
+SRC_URI:append:yosemitev2 = " file://power-config-host1.json"
+SRC_URI:append:yosemitev2 = " file://power-config-host2.json"
+SRC_URI:append:yosemitev2 = " file://power-config-host3.json"
+SRC_URI:append:yosemitev2 = " file://power-config-host4.json"
+
+do_install:append:yosemitev2() {
+    install -m 0755 -d ${D}/${datadir}/${BPN}
+    install -m 0644 -D ${WORKDIR}/*.json \
+                   ${D}/${datadir}/${BPN}/
+}