overlay: remove OBMC_PHOSPHOR_IMAGE_OVERLAY

Solve the problem resulting in the addition of this variable
differently, such that it can be removed and image type
selection can be selected in the standard way using IMAGE_FSTYPES.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: Ice94e8f278f00b8b4d344244bfb87dddeb173a23
diff --git a/meta-phosphor/classes/obmc-phosphor-debug-tarball.bbclass b/meta-phosphor/classes/obmc-phosphor-debug-tarball.bbclass
index 0e5dbd2..a7d2dc4 100644
--- a/meta-phosphor/classes/obmc-phosphor-debug-tarball.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-debug-tarball.bbclass
@@ -1,7 +1,11 @@
+# IMAGE_FSTYPES must appear before image.bbclass
+# is inherited otherwise image.bbclass will inherit
+# "live" image fstypes that we don't want.
+IMAGE_FSTYPES = "tar.xz"
+
 inherit image
 inherit obmc-phosphor-license
 
-IMAGE_FSTYPES = "tar.xz"
 IMAGE_INSTALL_append = " busybox packagegroup-obmc-phosphor-debugtools"
 
 # Override from image_types.bbclass to restrict tarball to /usr tree.