Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
index dddf9c0..093457e 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
@@ -1,22 +1,20 @@
+# To add additional config files, create a recipe in your layer,
+# and add it to PHOSPHOR_DBUS_MONITOR_CONFIGS with a bbappend to this recipe.
 SUMMARY = "Phosphor DBus Monitor Configuration"
 DESCRIPTION = "Meta-recipe, pulling in non-native recipes that wish to add \
 configuration files to the /usr/share/phosphor-dbus-monitor filesystem."
 HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
-PR = "r1"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+DEPENDS += "${PHOSPHOR_DBUS_MONITOR_CONFIGS}"
+PR = "r1"
 
 inherit phosphor-dbus-monitor
 
-PHOSPHOR_DBUS_MONITOR_CONFIGS ??= ""
-
-# To add additional config files, create a recipe in your layer,
-# and add it to PHOSPHOR_DBUS_MONITOR_CONFIGS with a bbappend to this recipe.
-
-DEPENDS += "${PHOSPHOR_DBUS_MONITOR_CONFIGS}"
-
 do_install() {
     mkdir -p ${D}${config_dir}
 }
 
 FILES:${PN} += "${config_dir}"
+
+PHOSPHOR_DBUS_MONITOR_CONFIGS ??= ""