Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb b/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
index a9123b1..31a0628 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
@@ -1,31 +1,28 @@
 SUMMARY = "Provides a host firmware image"
 DESCRIPTION = "Use a bbappend to add the image files"
+LICENSE = "${HOSTFW_LICENSE}"
+LIC_FILES_CHKSUM = "${HOSTFW_LIC_FILES_CHKSUM}"
 PR = "r1"
 
 inherit allarch
 inherit deploy
 
-HOSTFW_LICENSE ?= "Apache-2.0"
-HOSTFW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-LICENSE = "${HOSTFW_LICENSE}"
-LIC_FILES_CHKSUM = "${HOSTFW_LIC_FILES_CHKSUM}"
-
 do_compile() {
     # The image directory can be used as the source to create a filesystem to
     # add to the BMC image.
     install -d ${B}/image
-
     # Install an image-hostfw file in the update directory to be included in
     # the code update tarball.
     install -d ${B}/update
 }
 
+addtask deploy before do_build after do_compile
+
+HOSTFW_LICENSE ?= "Apache-2.0"
+HOSTFW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 do_deploy() {
     install -d ${DEPLOYDIR}/hostfw/image
     install -d ${DEPLOYDIR}/hostfw/update
     cp -R --no-dereference --preserve=mode,links ${B}/image/ ${DEPLOYDIR}/hostfw/
     cp -R --no-dereference --preserve=mode,links ${B}/update/ ${DEPLOYDIR}/hostfw/
 }
-
-addtask deploy before do_build after do_compile