Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
index e1c464b..4c70253 100644
--- a/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/health/phosphor-health-monitor_git.bb
@@ -1,21 +1,20 @@
 SUMMARY = "BMC Health Monitoring"
 DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
 HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
-PR = "r1"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
-
-inherit meson pkgconfig
-inherit systemd
-
 DEPENDS += "sdbusplus"
 DEPENDS += "phosphor-dbus-interfaces"
 DEPENDS += "sdeventplus"
 DEPENDS += "phosphor-logging"
 DEPENDS += "nlohmann-json"
+SRCREV = "b7d7bd5a384ea501766b15e4613eb9b14fe71e7f"
+PR = "r1"
 
 SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=https;branch=master"
-SRCREV = "b7d7bd5a384ea501766b15e4613eb9b14fe71e7f"
-S = "${WORKDIR}/git"
 
+S = "${WORKDIR}/git"
 SYSTEMD_SERVICE:${PN} = "phosphor-health-monitor.service"
+
+inherit meson pkgconfig
+inherit systemd