Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
index 9df4432..9b2e416 100644
--- a/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
+++ b/meta-phosphor/recipes-phosphor/images/obmc-phosphor-initramfs.bb
@@ -1,30 +1,26 @@
 DESCRIPTION = "Small image capable of booting a device. The kernel includes \
 the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
 first 'init' program more efficiently."
+LICENSE = "MIT"
+# Needed for the set_user_group functions to succeed
+DEPENDS += "shadow-native"
+
+inherit core-image
+
+export IMAGE_BASENAME = "obmc-phosphor-initramfs"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
+
+PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
+PACKAGE_INSTALL:remove = "shadow"
 
 # Init scripts
 INIT_PACKAGE = "obmc-phosphor-initfs"
 INIT_PACKAGE:df-phosphor-mmc = "phosphor-mmc-init"
-
-PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
-
 # Do not pollute the initrd image with rootfs features
 IMAGE_FEATURES = "read-only-rootfs"
-
-export IMAGE_BASENAME = "obmc-phosphor-initramfs"
 IMAGE_LINGUAS = ""
-
-LICENSE = "MIT"
-
 IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
-inherit core-image
-
 IMAGE_ROOTFS_SIZE = "8192"
 IMAGE_ROOTFS_EXTRA_SPACE = "0"
-
-# Needed for the set_user_group functions to succeed
-DEPENDS += "shadow-native"
-
-PACKAGE_INSTALL:remove = "shadow"
 PACKAGE_EXCLUDE = "shadow"
-BAD_RECOMMENDATIONS += "busybox-syslog"