Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index b3ba0a1..da9d945 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -1,28 +1,5 @@
-inherit systemd
-inherit useradd
-
-USERADD_PACKAGES = "${PN}"
-
-# add a user called httpd for the server to assume
-USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb"
-GROUPADD_PARAM:${PN} = "web; redfish"
-
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
-
-SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1"
-
-PV = "1.0+git${SRCPV}"
-SRCREV = "894744945e8f40a93fbcd6c100c92e0cf5b0ef67"
-
-S = "${WORKDIR}/git"
-
-inherit pkgconfig meson ptest
-
-SRC_URI += " \
-    file://run-ptest \
-"
-
 DEPENDS = " \
     openssl \
     zlib \
@@ -36,19 +13,20 @@
     ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
     ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
 "
+SRCREV = "894744945e8f40a93fbcd6c100c92e0cf5b0ef67"
+PV = "1.0+git${SRCPV}"
 
-RDEPENDS:${PN} += " \
-    jsnbd \
-    phosphor-mapper \
+SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1"
+SRC_URI += " \
+    file://run-ptest \
 "
 
-do_install_ptest() {
-        install -d ${D}${PTEST_PATH}/test
-        cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
-}
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
 
-FILES:${PN} += "${datadir}/** "
-
+inherit systemd
+inherit useradd
+inherit pkgconfig meson ptest
 
 EXTRA_OEMESON = " \
     --buildtype=minsize \
@@ -56,6 +34,21 @@
     -Dyocto-deps=enabled \
 "
 
-SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
+do_install_ptest() {
+        install -d ${D}${PTEST_PATH}/test
+        cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
+}
 
+RDEPENDS:${PN} += " \
+    jsnbd \
+    phosphor-mapper \
+"
+
+FILES:${PN} += "${datadir}/** "
+
+USERADD_PACKAGES = "${PN}"
+# add a user called httpd for the server to assume
+USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb"
+
+GROUPADD_PARAM:${PN} = "web; redfish"
 FULL_OPTIMIZATION = "-Os "